Topic: VC707 and FMC116 Cannot be configured by JTAG  (Read 7025 times)

ethanzhu July 24, 2014, 05:16 PM

  • Member
  • *
  • Posts: 30

When we test the demo project from the Page 61 of "4FM_Get_Started_Guide", we cannot program the FPGA through iMPACT.

The problem is if I just connect the FPGA to the laptop without plugging the FMC116 into FMC Port, I can program the FPGA quite well.
But when I plug FMC116 into FPGA, the iMPACT shows that:
PROGRESS_START - Starting Operation.
INFO:iMPACT:583 - '1': The idcode read from the device does not match

the idcode in the bsdl File.

INFO:iMPACT:1578 - '1':  Device IDCODE :        00000000000000000000000000000000

INFO:iMPACT:1579 - '1': Expected IDCODE:    00000011011010000111000010010011

And also shows "Program failed"

I think the problem should be referred to "The attached FMC card must implement a TDI-to-TDO connection via a device or bypass jumper to ensure

that the JTAG chain connects to the FPGA U1." on the page 26 of "ug885_VC707_Eval_Bd".

But I don't find the bypass jumper, could you tell me which connector or jumper is on FMC116?

Or if this is not the solution of the problem, could you tell how can I fix that, please?


Ethan
  • « Last Edit: July 24, 2014, 05:27 PM by ethanzhu »

arnaudNL July 28, 2014, 06:04 AM (#1)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Ethan,


Please do not double post on both private/public area. This does not speed up the process, I am locking this topic.


Best Regards,
Arnaud

arnaudNL July 29, 2014, 03:08 PM (#2)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
This topic is being closed because the issue is considered as resolved by 4DSP. Feel free to create a new topic for any further inquiries.