Topic: Need help with ADC  (Read 4310 times)

RuFuSS March 13, 2012, 12:25 AM

  • Member
  • *
  • Posts: 7
Hello,


I've been working with the FMC150 and have managed to get everything operational except the the ADC chip. No matter what I've done, the chip remains silent.


I believe the cause is that the input pins have been shorted to the grounds at the grounds.


Any steps that need to be taken to resolve this?


Thanks,
RuFuSS
  • « Last Edit: March 13, 2012, 03:21 AM by RuFuSS »

pierrehic March 13, 2012, 11:46 AM (#1)

  • 4DSP Staff (USA)
  • Administrator
  • Member
  • *****
  • Posts: 875
Hello,

Have you tried using the reference design delivered along with the FMC? What is your target hardware?

Thank you
Pierrick

RuFuSS March 13, 2012, 03:12 PM (#2)

  • Member
  • *
  • Posts: 7
I am connecting to the ML605, and using a reference design provided by avnet.

pierrehic March 13, 2012, 03:20 PM (#3)

  • 4DSP Staff (USA)
  • Administrator
  • Member
  • *****
  • Posts: 875
If the board does not operate properly with the reference design then you should request an RMA through Avnet.

Thanks
Pierrick

RuFuSS March 13, 2012, 03:44 PM (#4)

  • Member
  • *
  • Posts: 7
The board was purchased through 4DSP, the avnet reference design was just made available.

pierrehic March 13, 2012, 04:11 PM (#5)

  • 4DSP Staff (USA)
  • Administrator
  • Member
  • *****
  • Posts: 875
In that case, have you tried running the 4DSP reference design as well?

RuFuSS March 13, 2012, 04:24 PM (#6)

  • Member
  • *
  • Posts: 7
Currently I have not done the 4DSP reference design due to inability to follow any documentation on it.


Avnet's design was followed because of the clear order in operation.


Where can I find the 4DSP reference design?

RuFuSS March 13, 2012, 04:52 PM (#7)

  • Member
  • *
  • Posts: 7
I have already installed the package that was sent to me in an email.


I guess my question should have been: what is the top level file so that I can open it with xilinx?

pierrehic March 13, 2012, 05:06 PM (#8)

  • 4DSP Staff (USA)
  • Administrator
  • Member
  • *****
  • Posts: 875

RuFuSS March 14, 2012, 04:01 PM (#9)

  • Member
  • *
  • Posts: 7
The 4DSP reference design was run and clear input was seen through the ADC. Still trying to debug my code now.