Topic: Errors when running FMC webuart program  (Read 2357 times)

Peter77 August 21, 2014, 07:23 AM

  • Member
  • *
  • Posts: 10
Hi,
I encountered the following error message when running the fmc web uart program which I had compiled on the FMC667 card:
Verify_Init: Expected 16 entry count for gTxFreeQHnd queue 736, found 31 entries
Verify_Init: Expected 110 entry count for gRxFreeQHnd queue 738, found 160 entries
Verify_Init: Expected 0 entry count for gRxQHnd queue 704, found 42 entries
Verify_Init: Expected 0 entry count for queue 899, found 1 entries
Verify_Init: Expected 0 entry count for queue 4095, found 1 entries
I am using the fmc667 gel file supplied in the bsp.The problem is random with the errors most of the time although I can get the program to run without the above errors occassionally. Can you please advise what could be the problem?
Thanks!
 
 

arnaudNL August 21, 2014, 08:58 AM (#1)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Sir,


The problem description seems to match this issue: http://e2e.ti.com/support/dsp/c6000_multi-core_dsps/f/639/p/212702/752031.aspx


You should make sure to place the DSP in NO BOOT mode if you want to debug a code. You can do that from our reference software/firmware.


By default, the boot mode is SPI NOR Flash so it can boot the webserver from flash and the reference design override these settings as it uploads code using PCIe.


Look at SD215 or SD185 document, these are located in the firmware source code. There is description of the Dsp_boot_mode register and this is the way our reference software boots the DSP in PCIe mode.


Best Regards,
Arnaud

Peter77 August 24, 2014, 09:49 PM (#2)

  • Member
  • *
  • Posts: 10
Hi Arnaud,
 
Thanks for the help! The webuart program is now able to run correctly.
 
Thanks!

arnaudNL August 25, 2014, 04:44 AM (#3)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Sir,


Thanks for the feedback! Are you so far satisfied with the framework provided by 4DSP?


Best Regards,
Arnaud

arnaudNL August 27, 2014, 08:46 AM (#4)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
This topic is being closed because the issue is considered as resolved by 4DSP. Feel free to create a new topic for any further inquiries.