Topic: The Spur at the output of the DACs of FMC176  (Read 2488 times)

Clive.Boyd July 31, 2014, 02:47 AM

  • Member
  • *
  • Posts: 7
Dear all,
I am  using the DACs of the FMC176 board to  generate  a sinusoidal signal ( from 20 MHz to 600 MHz).
I already configured the PLL (AD9517) and the DACs (ADC 9129) correctly ( I used SPI for writing and reading back register's content; I also uses sample error detection (SED) technique to verify that the DACs receive correct digital inputs).
Unfortunately, when I look at the spectrum of the output of the DACs, there is a big spur at frequency of 1.75*fDAC. The frequency actually comes from 2*fDAC - fCO.  fDAC is the sampling rate of the  DAC and fCO is fDAC/4 which is used for data synchronization with FPGA digital stream.
The spur level is  35 db below the main signal.
Could you please advise me how to reduce this spurious power level to below 50 dB?
Best Regards,




arnaudNL July 31, 2014, 05:08 AM (#1)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Clive,


Could you please try to reproduce that with the reference design? Modify argument passed to GenerateWaveform16() in main.cpp to have the frequency you need. Let's see where that goes. There is also a function GetBufferFromFile() which called if LOADFROMFILE is defined in main.cpp. Typically this would search for a file called buffer1.txt and you can change that in the main.cpp also.


If you provide me with a FMC serial number I can look at the test report for that board.


I am attaching one buffer1.txt for your convenience. If you download Visual Analog from Analog Devices, a free tool, and you use the .vac attached you can display what the DAC buffer looks like. The same way you can display ADC buffers (adc0.txt, etc.). You could loop back ADC in to DAC out and visualize the buffer that way by simply running the application.


We need to figure out if spur is inherent to your design or not.


Best Regards,
Arnaud

arnaudNL August 04, 2014, 04:32 AM (#2)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Clive,


Have you been able to reproduce that with the default reference?


Thanks,
Arnaud

arnaudNL August 05, 2014, 07:03 AM (#3)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Clive,


Can you please update me, I will close the topic in 24 hours without news from your side.


Best Regards,
Arnaud

arnaudNL August 06, 2014, 11:09 AM (#4)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
This topic is being closed because the issue is considered as resolved by 4DSP. Feel free to create a new topic for any further inquiries.