Topic: FMC126 on VC707  (Read 4794 times)

pi-xel February 12, 2013, 01:38 PM

  • Member
  • *
  • Posts: 8
Hello!

Did anyone have success in executing Fmc12xApp.exe for FMC126 on VC707 board? I am using the reference bit file and get pattern check errors on ADC1 and ADC2 (first ADC seems to work well), and the fourth ADC doesn't seem to work at all (ADC D Phy clock is 0). I have connected the FMC126 to FMC HPC1 and use internal clock.

Is there maybe some mismatch in the UCF file? (just a guess)

Thanks in advance!

Philip

arnaudNL February 12, 2013, 03:58 PM (#1)

  • 4DSP Staff (EU)
  • Administrator
  • Member
  • *****
  • Posts: 7110
Dear Philip,
Sorry to hear about your issues with our hardware. Part of our test procedure is the bit file test on the actual hardware so I would not suspect the bit file yet.
Can you confirm you are actually cooling the FMC126? As per the user guide, it is important to have a proper airflow. On our side we are using small computer fans pointing towards the FMC126.
Do you have a FMC126 hardware revision 2.0? Old hardware revisions are not operating well on VC707.
Best Regards,
Arnaud

pi-xel February 13, 2013, 06:27 AM (#2)

  • Member
  • *
  • Posts: 8
Hey Arnaud,

Thanks for your quick response. I can confirm that proper cooling is ensured, tested the same setup successfully on ML605. And the label on the package says FMC126-2-1-1-1, so I guess that's revision 2 (on the board itself is written FMC12x r2). Any other ideas what might be wrong?

With best regards,
Philip

zhangxiang April 09, 2013, 08:02 AM (#3)

  • Member
  • *
  • Posts: 17
I am trying to program FMC126 without 4FM GUI. Is there any design file availabe? And I want to know how to program the CPLD's registers?